Selectievakjes invoegen in Excel 2010

Excel biedt zeer handige formulierbesturingen waarmee gebruikers een besturingselement kunnen maken en verschillende dingen tegelijkertijd kunnen bedienen. U kunt knoppen, selectievakjes, labels, combobox, scrolllijst enz. toevoegen. Het echte gebruik van formulierbesturingselementen kan worden bereikt wanneer u te maken hebt met kolossale datasheets en u verschillende functies en acties in de gewenste volgorde moet aanroepen. Deze bedieningselementen helpen u ook wanneer de datacellen met elkaar verbonden zijn. In dit bericht zullen we gebruiken Selectievakje vorm controle in een scenario waarin meer dan twee bereiken aan elkaar gerelateerd zijn.

Start Excel 2010 en maak een gegevensblad waarop u selectievakjes met verschillende acties wilt koppelen. Zo hebben we een presentielijst gemaakt van studenten, met daarin velden, Naam, en Aanwezigheid. We hebben heeft ook een andere tabel in onze datasheet opgenomen die velden bevat Totaal, Aanwezig, en Afwezig.



presentielijst

Om te beginnen, moeten we maken Ontwikkelaar tab zichtbaar in Excel-venster. Voor het geval je het niet vindt Ontwikkelaar tabblad, ga naar Bestand menu, klik op Opties, en klik in het linkerdeelvenster Lint aanpassen, vanuit het rechterdeelvenster inschakelen Ontwikkelaar selectievakje. Klik goed om zien Ontwikkelaar tabblad op het lint.

tabblad ontwikkelaars

Nu zullen we selectievakjes in het gegevensblad opnemen om tabelgegevens met een enkele klik te vullen. Navigeren naar Ontwikkelaar tabblad, van Invoegen opties, klik op selectievakje afbeelding aanwezig onder Formulier controles, zoals weergegeven in de onderstaande schermafbeelding.

ontwikkelaar

Als u klikt, ziet u de plustekenaanwijzer, klik op de plaats waar u het selectievakje wilt toevoegen.

selectievakje

Selecteer de tekst en verwijder deze, en klik er dan met de rechtermuisknop op, klik op Formaat controle.

klik met de rechtermuisknop

De Controle tabblad van Formaatbeheer dialoogvenster wordt geopend. Door mobiele link, selecteer de locatie in de datasheet waar u de check-/uncheck-status van checkbox wilt weergeven, die respectievelijk TRUE of FALSE zal zijn. Klik OK doorgaan.

selectievakje opties

Nu zullen we het selectievakje verplaatsen naar het einde van de aanwezigheid cel, zult u merken dat de cel waarnaar het verwijst H2 locatie, waardoor de waarden TRUE/FALSE worden gewijzigd.

vals 1

Als het selectievakje is ingeschakeld, wordt de waarde in de H2-locatie automatisch gewijzigd. We schrijven formule in Aanwezigheidszuil op locatie C2 , en dat zal de waarde in . controleren H2 plaats,

=ALS(H2=WAAR, Aanwezig, Afwezig)

De eerste parameter van de formule H2=WAAR, controleert de waarde in H2 dat als het WAAR is, trefwoord Cadeau zal in de cel verschijnen, en als het False is dan Afwezig verschijnt in de cel.

Aanwezigheid 1

Volg nu dezelfde procedure voor het opnemen van selectievakjes met alle cellen erin aanwezigheid veld. Zoals u in de onderstaande schermafbeelding kunt zien, hebben we selectievakjes met de cellen gemaakt en waar het selectievakje is ingeschakeld, verandert de corresponderende waarde in de H2-kolom in TRUE, uiteindelijk door de formule-evaluatie de Cadeau verschijnt in de overeenkomstige cel in het veld Aanwezigheid.

complete tafel

Nu zullen we beginnen met het vullen van de volgende tabel, hier zijn we ingevoerd 10 in totaal rij (aangezien we 10 studenten hebben) .

volgende tafel 1

We tellen het voorkomen van trefwoord Cadeau in de tafel aanwezigheid kolom . Dus we zullen de formule schrijven als;

=AANTAL.ALS(C2:C11, Aanwezig)

Het resultaat is 9, aangezien er maar één leerling afwezig is.

huidige studs `1

Om te controleren hoeveel studenten afwezig zijn, trekken we eenvoudig het aantal aanwezige studenten af ​​van het totale aantal studenten. De formule gaat als volgt

=($B-$B)

Het zal eenvoudig de waarde op B15 (aanwezige studenten) aftrekken van de waarde op B14 (Totaal), en het gewenste resultaat opleveren.

aanwezigheid afwezig

U zult ook merken dat bij het in-/uitschakelen van het selectievakje alle gerelateerde informatie automatisch wordt bijgewerkt.

compleet

U kunt ook eerder beoordeelde handleidingen bekijken opMacro's gebruiken via knoppen&Cameratool gebruiken in Excel 2010.

Ontvang dagelijkse tips in je inbox Nieuwsbrief Doe mee 35.000+ andere lezers
Hoe afstand te meten met de Google Maps-app Vorige Artikel

Hoe afstand te meten met de Google Maps-app

Hoe een VPN op Netflix te gebruiken om regionale blokkades te omzeilen (2022) Lees Verder

Hoe een VPN op Netflix te gebruiken om regionale blokkades te omzeilen (2022)